This incident has been resolved. We also identified the root cause and are working to ensure it does not happen again in the future.
Identified
Identified
We have increased the number of workers to process the delayed jobs. The documents should be completed shortly.
Investigating
Investigating
We have a temporary delay in document finalization and signature handling due to a surge in background task processing. We are investigating the root cause.