Started over 1 year agoApril 14, 2025Lasted 12 minutesApril 14, 202512:3112:44 PMUTC
Affected
Docue
Operational from 12:31 PM to 12:44 PM
Updates
Resolved
UTC
Resolved
UTC
The queue has been processed, and the system is operating normally.
Identified
UTC
Identified
UTC
We have a temporary delay in document finalization and signature handling due to a surge in background task processing following recent service changes. The issue has been identified, and we've increased allocated resources.