Started about 1 year agoMay 14, 2025Lasted about 2 hoursMay 14, 202512:562:44 PMUTC
Affected
Docue
Operational from 12:56 PM to 2:44 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
We have a temporary delay in document finalization and signature handling due to a surge in background task processing following recent service changes. The issue has been identified, and we've increased allocated resources.