Docue - Duplicate document completion notifications – Incident details

All systems operational

Duplicate document completion notifications

Resolved
Operational
Started 7 days agoLasted about 9 hours

Affected

Docue

Degraded performance from 10:55 AM to 12:50 PM, Operational from 12:50 PM to 7:42 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Issue is now resolved, but we are continuing to monitor the situation closely.

  • Investigating
    Investigating

    We've received reports of users receiving SMS & email notifications twice for completed documents.